summaryrefslogtreecommitdiffstats
path: root/gst-libs/gst/audio/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2004-01-16 00:55:29 +0000
committerDavid Schleef <ds@schleef.org>2004-01-16 00:55:29 +0000
commit7d64f26d2546be8ff1bcc4bb851108cb50384c58 (patch)
tree8ec2bfc3fdd7244c33946a34e685a124fffbc985 /gst-libs/gst/audio/Makefile.am
parent5404ac52f9ea35330439cce0cce266fab8649e14 (diff)
downloadgst-plugins-bad-7d64f26d2546be8ff1bcc4bb851108cb50384c58.tar.gz
gst-plugins-bad-7d64f26d2546be8ff1bcc4bb851108cb50384c58.tar.bz2
gst-plugins-bad-7d64f26d2546be8ff1bcc4bb851108cb50384c58.zip
gst-libs/gst/audio/Makefile.am: Add gstaudiofiltertemplate.c and building of gstaudiofilterexample.c from the template.
Original commit message from CVS: * gst-libs/gst/audio/Makefile.am: Add gstaudiofiltertemplate.c and building of gstaudiofilterexample.c from the template. * gst-libs/gst/audio/gstaudiofilter.c: * gst-libs/gst/audio/gstaudiofilter.h: Add bytes_per_sample and size and n_samples calculation. * gst-libs/gst/audio/gstaudiofilterexample.c: Remove, now autogenerated. * gst-libs/gst/audio/gstaudiofiltertemplate.c: Moved from gstaudiofilterexample, object name changed, code added so that it actually works. * gst-libs/gst/audio/make_filter: Script to build an audiofilter subclass from the template. * gst/colorspace/Makefile.am: * gst/colorspace/yuv2yuv.c: Remove file, since it's GPL, and we don't use it.
Diffstat (limited to 'gst-libs/gst/audio/Makefile.am')
-rw-r--r--gst-libs/gst/audio/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/gst-libs/gst/audio/Makefile.am b/gst-libs/gst/audio/Makefile.am
index d99cbcc6..ac16d969 100644
--- a/gst-libs/gst/audio/Makefile.am
+++ b/gst-libs/gst/audio/Makefile.am
@@ -2,6 +2,9 @@ librarydir = $(libdir)/gstreamer-@GST_MAJORMINOR@
library_LTLIBRARIES = libgstaudio.la libgstaudiofilter.la libgstaudiofilterexample.la
+EXTRA_DIST = gstaudiofiltertemplate.c make_filter
+CLEANFILES = gstaudiofilterexample.c
+
libgstaudio_la_SOURCES = audio.c audioclock.c
libgstaudioincludedir = $(includedir)/gstreamer-@GST_MAJORMINOR@/gst/audio
@@ -19,3 +22,5 @@ libgstaudiofilterexample_la_SOURCES = gstaudiofilterexample.c
libgstaudiofilterexample_la_CFLAGS = $(GST_CFLAGS)
libgstaudiofilterexample_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+gstaudiofilterexample.c: $(srcdir)/make_filter $(srcdir)/gstaudiofiltertemplate.c
+ $(srcdir)/make_filter AudiofilterExample $(srcdir)/gstaudiofiltertemplate.c