summaryrefslogtreecommitdiffstats
path: root/gst/app/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2007-02-26 21:01:03 +0000
committerDavid Schleef <ds@schleef.org>2007-02-26 21:01:03 +0000
commit5fd12e6daebda436c405f9c7d3cb7561b492e9ab (patch)
tree35b1b15e783f9f5806f2f79b7c8a7e740c9b1ba7 /gst/app/Makefile.am
parent13f01565870862c80e9485ebaf4a9e95ff2cea58 (diff)
downloadgst-plugins-bad-5fd12e6daebda436c405f9c7d3cb7561b492e9ab.tar.gz
gst-plugins-bad-5fd12e6daebda436c405f9c7d3cb7561b492e9ab.tar.bz2
gst-plugins-bad-5fd12e6daebda436c405f9c7d3cb7561b492e9ab.zip
Add a new plugin/library to make it easy for apps to shove data into a pipeline.
Original commit message from CVS: * configure.ac: * gst/app/Makefile.am: * gst/app/gstapp.c: * gst/app/gstappsrc.c: * gst/app/gstappsrc.h: Add a new plugin/library to make it easy for apps to shove data into a pipeline.
Diffstat (limited to 'gst/app/Makefile.am')
-rw-r--r--gst/app/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/gst/app/Makefile.am b/gst/app/Makefile.am
new file mode 100644
index 00000000..d232d330
--- /dev/null
+++ b/gst/app/Makefile.am
@@ -0,0 +1,18 @@
+lib_LTLIBRARIES = libgstapp-0.10.la
+
+plugin_LTLIBRARIES = libgstapp.la
+
+libgstapp_la_SOURCES = gstapp.c
+libgstapp_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS)
+libgstapp_la_LIBADD = $(GST_BASE_LIBS) libgstapp-0.10.la
+libgstapp_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+libgstapp_0_10_la_SOURCES = gstappsrc.c
+libgstapp_0_10_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS)
+libgstapp_0_10_la_LIBADD = $(GST_BASE_LIBS)
+libgstapp_0_10_la_LDFLAGS = $(GST_LDFLAGS)
+
+noinst_HEADERS = gstappsrc.h
+