summaryrefslogtreecommitdiffstats
path: root/gst/audioresample/Makefile.am
diff options
context:
space:
mode:
authorDavid Schleef <ds@schleef.org>2005-08-23 19:29:38 +0000
committerDavid Schleef <ds@schleef.org>2005-08-23 19:29:38 +0000
commitbde8ec9bf7f84427f403755282b45d3994fad7ce (patch)
tree48577ddcb554ad57e60efc77881eabf63610aff7 /gst/audioresample/Makefile.am
parent3a9fc486801df3e37e59843dad52022732708105 (diff)
downloadgst-plugins-bad-bde8ec9bf7f84427f403755282b45d3994fad7ce.tar.gz
gst-plugins-bad-bde8ec9bf7f84427f403755282b45d3994fad7ce.tar.bz2
gst-plugins-bad-bde8ec9bf7f84427f403755282b45d3994fad7ce.zip
gst/audioresample/Makefile.am: Leet audioresampling code
Original commit message from CVS: * gst/audioresample/Makefile.am: Leet audioresampling code * gst/audioresample/buffer.c: * gst/audioresample/buffer.h: * gst/audioresample/debug.c: * gst/audioresample/debug.h: * gst/audioresample/functable.c: * gst/audioresample/functable.h: * gst/audioresample/gstaudioresample.c: * gst/audioresample/gstaudioresample.h: * gst/audioresample/resample.c: * gst/audioresample/resample.h: * gst/audioresample/resample_chunk.c: * gst/audioresample/resample_functable.c: * gst/audioresample/resample_ref.c:
Diffstat (limited to 'gst/audioresample/Makefile.am')
-rw-r--r--gst/audioresample/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/gst/audioresample/Makefile.am b/gst/audioresample/Makefile.am
new file mode 100644
index 00000000..bff05034
--- /dev/null
+++ b/gst/audioresample/Makefile.am
@@ -0,0 +1,21 @@
+
+plugin_LTLIBRARIES = libgstaudioresample.la
+
+resample_SOURCES = \
+ functable.c \
+ functable.h \
+ resample.c \
+ resample_functable.c \
+ resample_ref.c \
+ resample_chunk.c \
+ resample.h \
+ debug.c \
+ debug.h \
+ buffer.c \
+ buffer.h
+
+libgstaudioresample_la_SOURCES = gstaudioresample.c $(resample_SOURCES)
+libgstaudioresample_la_CFLAGS = $(GST_CFLAGS) $(LIBOIL_CFLAGS)
+libgstaudioresample_la_LIBADD = $(LIBOIL_LIBS)
+libgstaudioresample_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+