summaryrefslogtreecommitdiffstats
path: root/gst/mpegdemux/Makefile.am
diff options
context:
space:
mode:
authorZaheer Abbas Merali <zaheerabbas@merali.org>2008-09-02 12:04:32 +0000
committerZaheer Abbas Merali <zaheerabbas@merali.org>2008-09-02 12:04:32 +0000
commit555486f865d6933da9cf983fc161e56474468ec4 (patch)
treeebfbbef762ce08fa4beb43e2abfd95851d78ce76 /gst/mpegdemux/Makefile.am
parent0ce15bab49aca60f380e186c47bcb0ebe4999367 (diff)
downloadgst-plugins-bad-555486f865d6933da9cf983fc161e56474468ec4.tar.gz
gst-plugins-bad-555486f865d6933da9cf983fc161e56474468ec4.tar.bz2
gst-plugins-bad-555486f865d6933da9cf983fc161e56474468ec4.zip
Add Fluendo MPEG PS and TS demuxers to gst-plugins-bad. This is now dual licensed MPL and LGPL.
Original commit message from CVS: * configure.ac: * gst/mpegdemux/Makefile.am: * gst/mpegdemux/flumpegdemux.c: * gst/mpegdemux/flutspatinfo.c: * gst/mpegdemux/flutspatinfo.h: * gst/mpegdemux/flutspmtinfo.c: * gst/mpegdemux/flutspmtinfo.h: * gst/mpegdemux/flutspmtstreaminfo.c: * gst/mpegdemux/flutspmtstreaminfo.h: * gst/mpegdemux/gstmpegdefs.h: * gst/mpegdemux/gstmpegdemux.c: * gst/mpegdemux/gstmpegdemux.h: * gst/mpegdemux/gstmpegdesc.c: * gst/mpegdemux/gstmpegdesc.h: * gst/mpegdemux/gstmpegtsdemux.c: * gst/mpegdemux/gstmpegtsdemux.h: * gst/mpegdemux/gstpesfilter.c: * gst/mpegdemux/gstpesfilter.h: * gst/mpegdemux/gstsectionfilter.c: * gst/mpegdemux/gstsectionfilter.h: Add Fluendo MPEG PS and TS demuxers to gst-plugins-bad. This is now dual licensed MPL and LGPL.
Diffstat (limited to 'gst/mpegdemux/Makefile.am')
-rw-r--r--gst/mpegdemux/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/gst/mpegdemux/Makefile.am b/gst/mpegdemux/Makefile.am
new file mode 100644
index 00000000..e0784750
--- /dev/null
+++ b/gst/mpegdemux/Makefile.am
@@ -0,0 +1,28 @@
+plugin_LTLIBRARIES = libgstmpegdemux.la
+
+libgstmpegdemux_la_SOURCES = \
+ flumpegdemux.c \
+ flutspatinfo.c \
+ flutspmtinfo.c \
+ flutspmtstreaminfo.c \
+ gstmpegdemux.c \
+ gstmpegdesc.c \
+ gstmpegtsdemux.c \
+ gstpesfilter.c \
+ gstsectionfilter.c
+
+libgstmpegdemux_la_CFLAGS = $(GST_CFLAGS) $(LIBOIL_CFLAGS)
+libgstmpegdemux_la_LIBADD = $(GST_BASE_LIBS) $(GST_LIBS) $(LIBOIL_LIBS)
+libgstmpegdemux_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = \
+ gstmpegdefs.h \
+ gstmpegdesc.h \
+ gstmpegdemux.h \
+ gstpesfilter.h \
+ gstmpegtsdemux.h \
+ flutspatinfo.h \
+ flutspmtinfo.h \
+ flutspmtstreaminfo.h \
+ gstsectionfilter.h
+