summaryrefslogtreecommitdiffstats
path: root/gst/mxf/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2008-11-28 18:13:30 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-11-28 18:13:30 +0000
commite268611ed89350024e42b1ef89601b58dc18e175 (patch)
tree032310038c79fd718030f4b9eb6be281d47d0ddc /gst/mxf/Makefile.am
parent4215682bf3232ba87108c37782cf1c178a8768a3 (diff)
downloadgst-plugins-bad-e268611ed89350024e42b1ef89601b58dc18e175.tar.gz
gst-plugins-bad-e268611ed89350024e42b1ef89601b58dc18e175.tar.bz2
gst-plugins-bad-e268611ed89350024e42b1ef89601b58dc18e175.zip
gst/mxf/: Add support for A-Law encoded audio essence (SMPTE 388M and 382M).
Original commit message from CVS: * gst/mxf/Makefile.am: * gst/mxf/mxfaes-bwf.c: (mxf_bwf_create_caps): * gst/mxf/mxfalaw.c: (mxf_is_alaw_audio_essence_track), (mxf_alaw_handle_essence_element), (mxf_alaw_create_caps): * gst/mxf/mxfalaw.h: * gst/mxf/mxfdemux.c: (gst_mxf_demux_handle_header_metadata_update_streams): Add support for A-Law encoded audio essence (SMPTE 388M and 382M).
Diffstat (limited to 'gst/mxf/Makefile.am')
-rw-r--r--gst/mxf/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/gst/mxf/Makefile.am b/gst/mxf/Makefile.am
index 6b1529f5..61f15456 100644
--- a/gst/mxf/Makefile.am
+++ b/gst/mxf/Makefile.am
@@ -6,7 +6,8 @@ libgstmxf_la_SOURCES = \
mxfparse.c \
mxfaes-bwf.c \
mxfmpeg.c \
- mxfdv-dif.c
+ mxfdv-dif.c \
+ mxfalaw.c
libgstmxf_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS)
libgstmxf_la_LIBADD = $(GST_LIBS) $(GST_BASE_LIBS)
@@ -18,5 +19,6 @@ noinst_HEADERS = \
mxfaes-bwf.h \
mxfmpeg.h \
mxfdv-dif.h \
+ mxfalaw.h \
mxftypes.h