summaryrefslogtreecommitdiffstats
path: root/gst/mxf/Makefile.am
diff options
context:
space:
mode:
authorSebastian Dröge <slomo@circular-chaos.org>2008-12-18 17:49:08 +0000
committerSebastian Dröge <slomo@circular-chaos.org>2008-12-18 17:49:08 +0000
commitecc0e9221fcfa3f46459b1f9c954298f93f72779 (patch)
tree30b4219f51797b302a820bbd67ff9b575bb3c54e /gst/mxf/Makefile.am
parent59c80c9a40b0b8bcdaddaa3dcb2b7260027ad1ac (diff)
downloadgst-plugins-bad-ecc0e9221fcfa3f46459b1f9c954298f93f72779.tar.gz
gst-plugins-bad-ecc0e9221fcfa3f46459b1f9c954298f93f72779.tar.bz2
gst-plugins-bad-ecc0e9221fcfa3f46459b1f9c954298f93f72779.zip
gst/mxf/: Add support for VC-3 (aka DNxHD essence, see SMPTE 2019-4).
Original commit message from CVS: * gst/mxf/Makefile.am: * gst/mxf/mxf.c: (plugin_init): * gst/mxf/mxfvc3.c: (mxf_is_vc3_essence_track), (mxf_vc3_handle_essence_element), (mxf_vc3_create_caps), (mxf_vc3_init): * gst/mxf/mxfvc3.h: Add support for VC-3 (aka DNxHD essence, see SMPTE 2019-4). This is untested because of lack of sample files but should work fine.
Diffstat (limited to 'gst/mxf/Makefile.am')
-rw-r--r--gst/mxf/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/gst/mxf/Makefile.am b/gst/mxf/Makefile.am
index 96e5720e..397d41a0 100644
--- a/gst/mxf/Makefile.am
+++ b/gst/mxf/Makefile.am
@@ -11,6 +11,7 @@ libgstmxf_la_SOURCES = \
mxfjpeg2000.c \
mxfd10.c \
mxfup.c \
+ mxfvc3.c \
mxfmetadata.c
libgstmxf_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
@@ -28,6 +29,7 @@ noinst_HEADERS = \
mxfjpeg2000.h \
mxfd10.h \
mxfup.h \
+ mxfvc3.h \
mxftypes.h \
mxfmetadata.h