summaryrefslogtreecommitdiffstats
path: root/gst/switch/Makefile.am
diff options
context:
space:
mode:
authorJulien Moutte <julien@moutte.net>2003-12-08 20:01:01 +0000
committerJulien Moutte <julien@moutte.net>2003-12-08 20:01:01 +0000
commit537891db4127e8fe27c1038e6ff088df3d520008 (patch)
tree9f8515d0075723ccd405146fc9efcdf818cf0efc /gst/switch/Makefile.am
parenteb652be7e1a4582ed8dc9e4749eebc3884046cd1 (diff)
downloadgst-plugins-bad-537891db4127e8fe27c1038e6ff088df3d520008.tar.gz
gst-plugins-bad-537891db4127e8fe27c1038e6ff088df3d520008.tar.bz2
gst-plugins-bad-537891db4127e8fe27c1038e6ff088df3d520008.zip
Adding a new plugin: switch.
Original commit message from CVS: Adding a new plugin: switch. It takes N input and only has 1 output. You can "switch" the forwarded input through properties ("nb_sources", "active_source") and i will probably add tuner interface support soon. It should be able to handle any kind of data passing through it. It is still a work in progress don't consider it usable for production yet.
Diffstat (limited to 'gst/switch/Makefile.am')
-rw-r--r--gst/switch/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/gst/switch/Makefile.am b/gst/switch/Makefile.am
new file mode 100644
index 00000000..fcac882e
--- /dev/null
+++ b/gst/switch/Makefile.am
@@ -0,0 +1,9 @@
+
+plugin_LTLIBRARIES = libgstswitch.la
+
+libgstswitch_la_SOURCES = gstswitch.c
+libgstswitch_la_CFLAGS = $(GST_CFLAGS)
+libgstswitch_la_LIBADD =
+libgstswitch_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = gstswitch.h