summaryrefslogtreecommitdiffstats
path: root/gst/videosignal/Makefile.am
diff options
context:
space:
mode:
authorWim Taymans <wim.taymans@gmail.com>2007-05-30 14:52:07 +0000
committerWim Taymans <wim.taymans@gmail.com>2007-05-30 14:52:07 +0000
commit853bb7b5dd839babdbac74ca9abfd30412b5b974 (patch)
tree934bc2a84160eeae2aca094f0726763f00dfa723 /gst/videosignal/Makefile.am
parent1f13109b20980f3b0cd9c409c922cd2329a830b7 (diff)
downloadgst-plugins-bad-853bb7b5dd839babdbac74ca9abfd30412b5b974.tar.gz
gst-plugins-bad-853bb7b5dd839babdbac74ca9abfd30412b5b974.tar.bz2
gst-plugins-bad-853bb7b5dd839babdbac74ca9abfd30412b5b974.zip
Added videosignal plugin with two plugins to analyse video frames.
Original commit message from CVS: * configure.ac: * docs/plugins/Makefile.am: * docs/plugins/gst-plugins-bad-plugins-docs.sgml: * docs/plugins/gst-plugins-bad-plugins-sections.txt: * docs/plugins/inspect/plugin-videosignal.xml: * gst/videosignal/Makefile.am: * gst/videosignal/gstvideoanalyse.c: (gst_video_analyse_set_caps), (gst_video_analyse_post_message), (gst_video_analyse_420), (gst_video_analyse_transform_ip), (gst_video_analyse_set_property), (gst_video_analyse_get_property), (gst_video_analyse_base_init), (gst_video_analyse_class_init), (gst_video_analyse_init), (gst_video_analyse_get_type): * gst/videosignal/gstvideoanalyse.h: * gst/videosignal/gstvideodetect.c: (gst_video_detect_set_caps), (gst_video_detect_post_message), (gst_video_detect_calc_brightness), (gst_video_detect_420), (gst_video_detect_transform_ip), (gst_video_detect_set_property), (gst_video_detect_get_property), (gst_video_detect_base_init), (gst_video_detect_class_init), (gst_video_detect_init), (gst_video_detect_get_type): * gst/videosignal/gstvideodetect.h: * gst/videosignal/gstvideosignal.c: (plugin_init): * gst/videosignal/gstvideosignal.h: Added videosignal plugin with two plugins to analyse video frames. Added videoanalyse to report about brightness and variance in video frames. Added videodetect to detect predefined patterns in a video signal.
Diffstat (limited to 'gst/videosignal/Makefile.am')
-rw-r--r--gst/videosignal/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/gst/videosignal/Makefile.am b/gst/videosignal/Makefile.am
new file mode 100644
index 00000000..1877c4c0
--- /dev/null
+++ b/gst/videosignal/Makefile.am
@@ -0,0 +1,12 @@
+plugin_LTLIBRARIES = libgstvideosignal.la
+
+noinst_HEADERS = gstvideoanalyse.h gstvideodetect.h
+
+libgstvideosignal_la_SOURCES = gstvideosignal.c \
+ gstvideoanalyse.c \
+ gstvideodetect.c
+
+libgstvideosignal_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS)
+libgstvideosignal_la_LIBADD = $(GST_PLUGINS_BASE_LIBS) -lgstvideo-@GST_MAJORMINOR@ $(GST_BASE_LIBS) $(GST_LIBS)
+libgstvideosignal_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)