summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am12
1 files changed, 11 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 0eccbb0f..6fa0496e 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,8 +1,18 @@
DISTCHECK_CONFIGURE_FLAGS=--enable-gtk-doc
+if BUILD_EXAMPLES
+SUBDIRS_EXAMPLES = examples
+else
+SUBDIRS_EXAMPLES =
+endif
+
SUBDIRS = \
gst sys ext \
- m4 common docs
+ m4 common docs \
+ $(SUBDIRS_EXAMPLES)
+
+DIST_SUBDIRS = \
+ gst sys ext m4 common docs examples
EXTRA_DIST = \
gst-plugins-bad.spec depcomp \