summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac38
1 files changed, 23 insertions, 15 deletions
diff --git a/configure.ac b/configure.ac
index 6f10f531..220e081a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1505,28 +1505,36 @@ GST_CHECK_FEATURE(LIBPNG, [snapshot plug-in], snapshot, [
AC_SUBST(LIBPNG_LIBS)
])
-dnl *** speex 1.0.x or >= 1.1.5 (1.1.4 and earlier were not API/ABI compatible ***
-dnl speex_jitter.h is 1.1 only
+dnl *** speex 1.0.x or >= 1.1.5 ***
+dnl 1.1.4 and earlier were not API/ABI compatible with 1.0
+dnl 1.1.6 is the first to use a .pc/pkg-config file ***
+dnl speex_jitter.h is 1.1.x only
translit(dnm, m, l) AM_CONDITIONAL(USE_SPEEX, true)
GST_CHECK_FEATURE(SPEEX, [speex plug-in], speex, [
- GST_CHECK_LIBHEADER(SPEEX, speex, speex_bits_init, , speex.h, [
- AC_CHECK_HEADER(speex_jitter.h, [
- dnl speex 1.1.x :
- GST_CHECK_LIBHEADER(SPEEX, speex, speex_encode_int, , speex.h, [
- dnl speex 1.1.5 or + :
+ PKG_CHECK_MODULES(SPEEX, speex >= 1.1.6, [
+ HAVE_SPEEX="yes"
+ AC_SUBST(SPEEX_CFLAGS)
+ AC_SUBST(SPEEX_LIBS)
+ ], [
+ GST_CHECK_LIBHEADER(SPEEX, speex, speex_bits_init, , speex.h, [
+ AC_CHECK_HEADER(speex_jitter.h, [
+ dnl speex 1.1.x :
+ GST_CHECK_LIBHEADER(SPEEX, speex, speex_encode_int, , speex.h, [
+ dnl speex 1.1.5 or + :
+ HAVE_SPEEX="yes"
+ SPEEX_LIBS="-lspeex"
+ AC_SUBST(SPEEX_CFLAGS)
+ AC_SUBST(SPEEX_LIBS)
+ ],[
+ HAVE_SPEEX="no"
+ ])
+ ], [
+ dnl speex 1.0.x :
HAVE_SPEEX="yes"
SPEEX_LIBS="-lspeex"
AC_SUBST(SPEEX_CFLAGS)
AC_SUBST(SPEEX_LIBS)
- ],[
- HAVE_SPEEX="no"
])
- ], [
- dnl speex 1.0.x :
- HAVE_SPEEX="yes"
- SPEEX_LIBS="-lspeex"
- AC_SUBST(SPEEX_CFLAGS)
- AC_SUBST(SPEEX_LIBS)
])
])
])