summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac46
1 files changed, 45 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index cbf2b272..ca0822da 100644
--- a/configure.ac
+++ b/configure.ac
@@ -583,7 +583,50 @@ GST_CHECK_FEATURE(LIBPNG, [libpng PNG encoder], pngenc, [
AC_SUBST(LIBPNG_LIBS)
])
-
+dnl *** speex >= 1.0.4 or >= 1.1.5 ***
+dnl 1.1.4 and earlier were not API/ABI compatible with 1.0
+dnl 1.1.6 is the first to use a .pc/pkg-config file ***
+dnl speex_jitter.h is 1.1.x only
+translit(dnm, m, l) AM_CONDITIONAL(USE_SPEEX, true)
+GST_CHECK_FEATURE(SPEEX, [speex plug-in], speex, [
+ PKG_CHECK_MODULES(SPEEX, speex >= 1.1.6, [
+ HAVE_SPEEX="yes"
+ AC_SUBST(SPEEX_CFLAGS)
+ AC_SUBST(SPEEX_LIBS)
+ ], [
+ GST_CHECK_LIBHEADER(SPEEX, speex, speex_bits_init, , speex/speex.h, [
+ AC_CHECK_HEADER(speex/speex_jitter.h, [
+ dnl speex 1.1.x :
+ GST_CHECK_LIBHEADER(SPEEX, speex, speex_encode_int, , speex/speex.h, [
+ dnl speex 1.1.5 or + :
+ HAVE_SPEEX="yes"
+ SPEEX_LIBS="-lspeex"
+ AC_SUBST(SPEEX_CFLAGS)
+ AC_SUBST(SPEEX_LIBS)
+ ],[
+ HAVE_SPEEX="no"
+ ])
+ ],[
+ dnl speex 1.0.x :
+ AC_CHECK_DECL(SPEEX_GET_LOOKAHEAD, [
+ dnl speex 1.0.4
+ HAVE_SPEEX="yes"
+ SPEEX_LIBS="-lspeex"
+ AC_SUBST(SPEEX_CFLAGS)
+ AC_SUBST(SPEEX_LIBS)
+
+ AC_DEFINE_UNQUOTED(SPEEX_1_0, 1,
+ [defined if speex 1.0.x API detected])
+ ],[
+ HAVE_SPEEX="no"
+ AC_MSG_NOTICE(You need at least 1.0.4 to compile the speex plugin)
+ ], [
+#include <speex/speex.h>
+ ])
+ ])
+ ])
+ ])
+])
dnl also add builddir include for enumtypes and marshal
GST_CFLAGS="-I\$(top_srcdir)/gst-libs -I\$(top_builddir)/gst-libs $GST_CFLAGS $GST_ERROR"
@@ -676,6 +719,7 @@ ext/mad/Makefile
ext/raw1394/Makefile
ext/shout2/Makefile
ext/sidplay/Makefile
+ext/speex/Makefile
ext/esd/Makefile
ext/mpeg2dec/Makefile
ext/faad/Makefile