summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 18fa668c..c895edb3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -419,6 +419,14 @@ GST_CHECK_FEATURE(SDL, [SDL plug-in], sdlvideosink, [
AM_PATH_SDL(, HAVE_SDL=yes, HAVE_SDL=no)
])
+dnl *** swfdec ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_SWFDEC, true)
+GST_CHECK_FEATURE(SWFDEC, [swfdec plug-in], swfdec, [
+ PKG_CHECK_MODULES(SWFDEC, swfdec-0.3 >= 0.3.3, HAVE_SWFDEC=yes, HAVE_SWFDEC=no)
+ AC_SUBST(SWFDEC_CFLAGS)
+ AC_SUBST(SWFDEC_LIBS)
+])
+
dnl *** wavpack ***
dnl We ship our own version of the library
translit(dnm, m, l) AM_CONDITIONAL(USE_WAVPACK, true)
@@ -528,6 +536,7 @@ ext/Makefile
ext/directfb/Makefile
ext/faac/Makefile
ext/faad/Makefile
+ext/swfdec/Makefile
ext/wavpack/Makefile
ext/ivorbis/Makefile
ext/gsm/Makefile