summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 10 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6222af2d..294348d7 100644
--- a/configure.ac
+++ b/configure.ac
@@ -956,6 +956,14 @@ AG_GST_CHECK_FEATURE(LADSPA, [ladspa], ladspa, [
AC_SUBST(LRDF_CFLAGS)
])
+dnl *** LV2 ***
+translit(dnm, m, l) AM_CONDITIONAL(USE_LV2, true)
+AG_GST_CHECK_FEATURE(LV2, [lv2], lv2, [
+ PKG_CHECK_MODULES(SLV2, slv2 >= 0.6.0, HAVE_LV2="yes", HAVE_LV2="no")
+ AC_SUBST(SLV2_CFLAGS)
+ AC_SUBST(SLV2_LIBS)
+])
+
dnl *** libmms ***
translit(dnm, m, l) AM_CONDITIONAL(USE_LIBMMS, true)
AG_GST_CHECK_FEATURE(LIBMMS, [mms protocol library], libmms, [
@@ -1617,6 +1625,7 @@ gst-libs/Makefile
gst-libs/gst/Makefile
gst-libs/gst/dshow/Makefile
gst-libs/gst/interfaces/Makefile
+gst-libs/gst/signalprocessor/Makefile
sys/Makefile
sys/dshowdecwrapper/Makefile
sys/acmenc/Makefile
@@ -1660,6 +1669,7 @@ ext/ivorbis/Makefile
ext/jack/Makefile
ext/jp2k/Makefile
ext/ladspa/Makefile
+ext/lv2/Makefile
ext/libmms/Makefile
ext/Makefile
ext/nas/Makefile