summaryrefslogtreecommitdiffstats
path: root/docs/plugins/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'docs/plugins/Makefile.am')
-rw-r--r--docs/plugins/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/docs/plugins/Makefile.am b/docs/plugins/Makefile.am
index ac24fec2..73bdbf83 100644
--- a/docs/plugins/Makefile.am
+++ b/docs/plugins/Makefile.am
@@ -50,7 +50,7 @@ SCAN_OPTIONS=
#EXTRA_DIST = gstreamer.types.in gstreamer.hierarchy $(DOC_MODULE)-sections.txt gstreamer-sections.txt $(DOC_MAIN_SGML_FILE)
# Extra options to supply to gtkdoc-mkdb.
-MKDB_OPTIONS=--sgml-mode --source-suffixes=c,h,cc
+MKDB_OPTIONS=--sgml-mode --source-suffixes=c,h,cc,m
# Extra options to supply to gtkdoc-fixref.
FIXXREF_OPTIONS=--extra-dir=$(GLIB_PREFIX)/share/gtk-doc/html/gobject \
@@ -61,7 +61,7 @@ FIXXREF_OPTIONS=--extra-dir=$(GLIB_PREFIX)/share/gtk-doc/html/gobject \
# Used for dependencies.
HFILE_GLOB=$(DOC_SOURCE_DIR)/*/*/*.h
-CFILE_GLOB=$(DOC_SOURCE_DIR)/*/*/*.c $(DOC_SOURCE_DIR)/*/*/*.cc
+CFILE_GLOB=$(DOC_SOURCE_DIR)/*/*/*.c $(DOC_SOURCE_DIR)/*/*/*.cc $(DOC_SOURCE_DIR)/*/*/*.m
# this is a wingo addition
# thomasvs: another nice wingo addition would be an explanation on why
@@ -92,6 +92,7 @@ EXTRA_HFILES = \
$(top_srcdir)/sys/directdraw/gstdirectdrawsink.h \
$(top_srcdir)/sys/directsound/gstdirectsoundsink.h \
$(top_srcdir)/sys/waveform/gstwaveformsink.h \
+ $(top_srcdir)/sys/osxvideo/osxvideosink.h \
$(top_srcdir)/ext/directfb/dfbvideosink.h \
$(top_srcdir)/ext/jack/gstjackaudiosink.h \
$(top_srcdir)/ext/musicbrainz/gsttrm.h \