summaryrefslogtreecommitdiffstats
path: root/ext/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/Makefile.am')
-rw-r--r--ext/Makefile.am17
1 files changed, 15 insertions, 2 deletions
diff --git a/ext/Makefile.am b/ext/Makefile.am
index 3d1dd792..2b2aca01 100644
--- a/ext/Makefile.am
+++ b/ext/Makefile.am
@@ -1,3 +1,15 @@
+if USE_A52
+A52_DIR=a52
+else
+A52_DIR=
+endif
+
+if USE_AALIB
+AALIB_DIR=aalib
+else
+AALIB_DIR=
+endif
+
if USE_AUDIOFILE
AUDIOFILE_DIR=audiofile
else
@@ -35,7 +47,8 @@ VORBIS_DIR=
endif
-SUBDIRS=$(AUDIOFILE_DIR) $(ESD_DIR) $(LAME_DIR) $(MAD_DIR) \
+SUBDIRS=$(A52_DIR) $(AALIB_DIR) $(AUDIOFILE_DIR) $(ESD_DIR) \
+ $(LAME_DIR) $(MAD_DIR) \
$(SDL_DIR) $(VORBIS_DIR)
-DIST_SUBDIRS=audiofile esd lame mad sdl vorbis
+DIST_SUBDIRS=a52 aalib audiofile esd lame mad sdl vorbis