summaryrefslogtreecommitdiffstats
path: root/ext/mpeg2enc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/mpeg2enc/Makefile.am')
-rw-r--r--ext/mpeg2enc/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/ext/mpeg2enc/Makefile.am b/ext/mpeg2enc/Makefile.am
new file mode 100644
index 00000000..da5d01d1
--- /dev/null
+++ b/ext/mpeg2enc/Makefile.am
@@ -0,0 +1,18 @@
+plugin_LTLIBRARIES = libgstmpeg2enc.la
+
+libgstmpeg2enc_la_SOURCES = \
+ gstmpeg2enc.cc \
+ gstmpeg2encoptions.cc \
+ gstmpeg2encoder.cc \
+ gstmpeg2encstreamwriter.cc \
+ gstmpeg2encpicturereader.cc
+libgstmpeg2enc_la_CXXFLAGS = $(MPEG2ENC_CFLAGS) $(GST_CFLAGS)
+libgstmpeg2enc_la_LIBADD = $(MPEG2ENC_LIBS)
+libgstmpeg2enc_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = \
+ gstmpeg2enc.hh \
+ gstmpeg2encoder.hh \
+ gstmpeg2encoptions.hh \
+ gstmpeg2encstreamwriter.hh \
+ gstmpeg2encpicturereader.hh