summaryrefslogtreecommitdiffstats
path: root/ext/musepack/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/musepack/Makefile.am')
-rw-r--r--ext/musepack/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/ext/musepack/Makefile.am b/ext/musepack/Makefile.am
new file mode 100644
index 00000000..3c3b1bfa
--- /dev/null
+++ b/ext/musepack/Makefile.am
@@ -0,0 +1,12 @@
+plugin_LTLIBRARIES = libgstmusepack.la
+
+libgstmusepack_la_SOURCES = \
+ gstmusepackdec.cpp \
+ gstmusepackreader.cpp
+libgstmusepack_la_CXXFLAGS = $(MUSEPACK_CFLAGS) $(GST_CFLAGS)
+libgstmusepack_la_LIBADD = $(MUSEPACK_LIBS)
+libgstmusepack_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = \
+ gstmusepackdec.h \
+ gstmusepackreader.h