summaryrefslogtreecommitdiffstats
path: root/ext/neon/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/neon/Makefile.am')
-rw-r--r--ext/neon/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/ext/neon/Makefile.am b/ext/neon/Makefile.am
index 65fbf1ff..452913ee 100644
--- a/ext/neon/Makefile.am
+++ b/ext/neon/Makefile.am
@@ -4,8 +4,9 @@ plugin_LTLIBRARIES = libgstneonhttpsrc.la
libgstneonhttpsrc_la_SOURCES = gstneonhttpsrc.c
-
-libgstneonhttpsrc_la_CFLAGS = $(GST_CFLAGS) $(NEON_CFLAGS)
+libgstneonhttpsrc_la_CFLAGS = $(GST_CFLAGS) \
+ $(NEON_CFLAGS) \
+ -D_GNU_SOURCE
libgstneonhttpsrc_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
libgstneonhttpsrc_la_LIBADD = $(GST_BASE_LIBS) \
$(NEON_LIBS)