summaryrefslogtreecommitdiffstats
path: root/ext/resindvd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/resindvd/Makefile.am')
-rw-r--r--ext/resindvd/Makefile.am11
1 files changed, 7 insertions, 4 deletions
diff --git a/ext/resindvd/Makefile.am b/ext/resindvd/Makefile.am
index 9f4d3c8f..ace8fc33 100644
--- a/ext/resindvd/Makefile.am
+++ b/ext/resindvd/Makefile.am
@@ -12,10 +12,12 @@ libresindvd_la_SOURCES = \
resindvdsrc.c \
gstmpegdesc.c \
gstmpegdemux.c \
- gstpesfilter.c
+ gstpesfilter.c \
+ rsnparsetter.c \
+ rsnwrappedbuffer.c
-libresindvd_la_CFLAGS = $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(DVDNAV_CFLAGS)
-libresindvd_la_LIBADD = $(GST_BASE_LIBS) $(GST_LIBS) $(DVDNAV_LIBS)
+libresindvd_la_CFLAGS = $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(DVDNAV_CFLAGS)
+libresindvd_la_LIBADD = $(GST_PLUGINS_BASE_CFLAGS) -lgstvideo-$(GST_MAJORMINOR) $(GST_BASE_LIBS) $(GST_LIBS) $(DVDNAV_LIBS)
libresindvd_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = resindvdbin.h \
@@ -27,4 +29,5 @@ noinst_HEADERS = resindvdbin.h \
gstmpegdefs.h \
gstmpegdesc.h \
gstmpegdemux.h \
- gstpesfilter.h
+ gstpesfilter.h \
+ rsnparsetter.h