summaryrefslogtreecommitdiffstats
path: root/ext/resindvd/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/resindvd/Makefile.am')
-rw-r--r--ext/resindvd/Makefile.am30
1 files changed, 30 insertions, 0 deletions
diff --git a/ext/resindvd/Makefile.am b/ext/resindvd/Makefile.am
new file mode 100644
index 00000000..9f4d3c8f
--- /dev/null
+++ b/ext/resindvd/Makefile.am
@@ -0,0 +1,30 @@
+# plugindir is set in configure
+
+plugin_LTLIBRARIES = libresindvd.la
+
+libresindvd_la_SOURCES = \
+ plugin.c \
+ resindvdbin.c \
+ rsnaudiomunge.c \
+ rsnbasesrc.c \
+ rsnpushsrc.c \
+ rsnstreamselector.c \
+ resindvdsrc.c \
+ gstmpegdesc.c \
+ gstmpegdemux.c \
+ gstpesfilter.c
+
+libresindvd_la_CFLAGS = $(GST_BASE_CFLAGS) $(GST_CFLAGS) $(DVDNAV_CFLAGS)
+libresindvd_la_LIBADD = $(GST_BASE_LIBS) $(GST_LIBS) $(DVDNAV_LIBS)
+libresindvd_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = resindvdbin.h \
+ rsnaudiomunge.h \
+ rsnbasesrc.h \
+ rsnpushsrc.h \
+ rsnstreamselector.h \
+ resindvdsrc.h \
+ gstmpegdefs.h \
+ gstmpegdesc.h \
+ gstmpegdemux.h \
+ gstpesfilter.h