summaryrefslogtreecommitdiffstats
path: root/ext/sdl/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'ext/sdl/Makefile.am')
-rw-r--r--ext/sdl/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/ext/sdl/Makefile.am b/ext/sdl/Makefile.am
new file mode 100644
index 00000000..371ac789
--- /dev/null
+++ b/ext/sdl/Makefile.am
@@ -0,0 +1,11 @@
+plugindir = $(libdir)/gst
+
+plugin_LTLIBRARIES = libsdlvideosink.la
+libsdlvideosink_la_SOURCES = sdlvideosink.c
+
+
+## FIXME I have my doubts about these opti flags
+libsdlvideosink_la_CFLAGS = -ffast-math -finline-functions $(GST_CFLAGS) $(SDL_CFLAGS)
+libsdlvideosink_la_LIBADD = $(SDL_LIBS)
+
+noinst_HEADERS = sdlvideosink.h