summaryrefslogtreecommitdiffstats
path: root/gst-libs/gst/app/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst-libs/gst/app/Makefile.am')
-rw-r--r--gst-libs/gst/app/Makefile.am19
1 files changed, 18 insertions, 1 deletions
diff --git a/gst-libs/gst/app/Makefile.am b/gst-libs/gst/app/Makefile.am
index 83925c91..d39572aa 100644
--- a/gst-libs/gst/app/Makefile.am
+++ b/gst-libs/gst/app/Makefile.am
@@ -1,6 +1,19 @@
lib_LTLIBRARIES = libgstapp-@GST_MAJORMINOR@.la
-libgstapp_@GST_MAJORMINOR@_la_SOURCES = gstappsrc.c gstappbuffer.c gstappsink.c
+glib_enum_define = GST_APP
+glib_enum_prefix = gst_app
+
+include $(top_srcdir)/common/glib-gen.mak
+
+built_sources = gstapp-marshal.c
+built_headers = gstapp-marshal.h
+
+BUILT_SOURCES = $(built_sources) $(built_headers)
+
+nodist_libgstapp_@GST_MAJORMINOR@_la_SOURCES = \
+ $(built_sources)
+
+libgstapp_@GST_MAJORMINOR@_la_SOURCES = gstappsrc.c gstappbuffer.c gstappsink.c
libgstapp_@GST_MAJORMINOR@_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
$(GST_PLUGINS_BASE_CFLAGS)
libgstapp_@GST_MAJORMINOR@_la_LIBADD = $(GST_BASE_LIBS)
@@ -12,3 +25,7 @@ libgstapp_@GST_MAJORMINOR@include_HEADERS = \
gstappbuffer.h \
gstappsink.h
+CLEANFILES = $(BUILT_SOURCES)
+
+EXTRA_DIST = gstapp-marshal.list
+