summaryrefslogtreecommitdiffstats
path: root/gst/audioresample/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/audioresample/Makefile.am')
-rw-r--r--gst/audioresample/Makefile.am21
1 files changed, 21 insertions, 0 deletions
diff --git a/gst/audioresample/Makefile.am b/gst/audioresample/Makefile.am
new file mode 100644
index 00000000..bff05034
--- /dev/null
+++ b/gst/audioresample/Makefile.am
@@ -0,0 +1,21 @@
+
+plugin_LTLIBRARIES = libgstaudioresample.la
+
+resample_SOURCES = \
+ functable.c \
+ functable.h \
+ resample.c \
+ resample_functable.c \
+ resample_ref.c \
+ resample_chunk.c \
+ resample.h \
+ debug.c \
+ debug.h \
+ buffer.c \
+ buffer.h
+
+libgstaudioresample_la_SOURCES = gstaudioresample.c $(resample_SOURCES)
+libgstaudioresample_la_CFLAGS = $(GST_CFLAGS) $(LIBOIL_CFLAGS)
+libgstaudioresample_la_LIBADD = $(LIBOIL_LIBS)
+libgstaudioresample_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+