summaryrefslogtreecommitdiffstats
path: root/gst/deinterlace2/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/deinterlace2/Makefile.am')
-rw-r--r--gst/deinterlace2/Makefile.am38
1 files changed, 19 insertions, 19 deletions
diff --git a/gst/deinterlace2/Makefile.am b/gst/deinterlace2/Makefile.am
index 1af5a910..d6e38c91 100644
--- a/gst/deinterlace2/Makefile.am
+++ b/gst/deinterlace2/Makefile.am
@@ -3,12 +3,29 @@ plugin_LTLIBRARIES = libgstdeinterlace2.la
libgstdeinterlace2_la_SOURCES = \
gstdeinterlace2.c \
tvtime/greedy.c \
- tvtime/greedyh.asm \
tvtime/greedyh.c \
tvtime/speedy.c \
tvtime/vfir.c \
+ tvtime/tomsmocomp.c
+
+libgstdeinterlace2_la_CFLAGS = $(GST_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(LIBOIL_CFLAGS) -DHAVE_MMX -DHAVE_SSE
+libgstdeinterlace2_la_LIBADD = $(GST_LIBS) \
+ $(GST_PLUGINS_BASE_LIBS) -lgstvideo-$(GST_MAJORMINOR) $(GST_BASE_LIBS) $(LIBOIL_LIBS)
+libgstdeinterlace2_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = \
+ gstdeinterlace2.h \
+ tvtime/mmx.h \
+ tvtime/sse.h \
+ tvtime/greedyh.h \
+ tvtime/greedyh.asm \
+ tvtime/greedyhmacros.h \
+ tvtime/plugins.h \
+ tvtime/speedtools.h \
+ tvtime/speedy.h \
tvtime/x86-64_macros.inc \
- tvtime/tomsmocomp.c \
+ tvtime/tomsmocomp.h \
tvtime/tomsmocomp/SearchLoop0A.inc \
tvtime/tomsmocomp/SearchLoopBottom.inc \
tvtime/tomsmocomp/SearchLoopEdgeA8.inc \
@@ -27,20 +44,3 @@ libgstdeinterlace2_la_SOURCES = \
tvtime/tomsmocomp/tomsmocompmacros.h \
tvtime/tomsmocomp/WierdBob.inc
-libgstdeinterlace2_la_CFLAGS = $(GST_CFLAGS) \
- $(GST_PLUGINS_BASE_CFLAGS) $(GST_BASE_CFLAGS) $(LIBOIL_CFLAGS) -DHAVE_MMX -DHAVE_SSE
-libgstdeinterlace2_la_LIBADD = $(GST_LIBS) \
- $(GST_PLUGINS_BASE_LIBS) -lgstvideo-$(GST_MAJORMINOR) $(GST_BASE_LIBS) $(LIBOIL_LIBS)
-libgstdeinterlace2_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
-
-noinst_HEADERS = \
- gstdeinterlace2.h \
- tvtime/mmx.h \
- tvtime/sse.h \
- tvtime/greedyh.h \
- tvtime/greedyhmacros.h \
- tvtime/plugins.h \
- tvtime/speedtools.h \
- tvtime/speedy.h \
- tvtime/tomsmocomp.h
-