summaryrefslogtreecommitdiffstats
path: root/gst/interleave/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/interleave/Makefile.am')
-rw-r--r--gst/interleave/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/gst/interleave/Makefile.am b/gst/interleave/Makefile.am
index 62e7f3e3..3477933c 100644
--- a/gst/interleave/Makefile.am
+++ b/gst/interleave/Makefile.am
@@ -2,8 +2,8 @@
plugin_LTLIBRARIES = libgstinterleave.la
libgstinterleave_la_SOURCES = plugin.c interleave.c deinterleave.c
-libgstinterleave_la_CFLAGS = $(GST_CFLAGS)
-libgstinterleave_la_LIBADD = $(GST_LIBS)
+libgstinterleave_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) $(GST_PLUGINS_BASE_CFLAGS)
+libgstinterleave_la_LIBADD = $(GST_LIBS) $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS) -lgstaudio-$(GST_MAJORMINOR)
libgstinterleave_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = plugin.h interleave.h deinterleave.h