summaryrefslogtreecommitdiffstats
path: root/gst/librfb/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/librfb/Makefile.am')
-rw-r--r--gst/librfb/Makefile.am26
1 files changed, 10 insertions, 16 deletions
diff --git a/gst/librfb/Makefile.am b/gst/librfb/Makefile.am
index 7c80112f..b93291df 100644
--- a/gst/librfb/Makefile.am
+++ b/gst/librfb/Makefile.am
@@ -1,4 +1,3 @@
-
# please keep librfb easily extractable
noinst_LTLIBRARIES = librfb.la
@@ -6,26 +5,21 @@ plugin_LTLIBRARIES = libgstrfbsrc.la
libgstrfbsrc_la_SOURCES = gstrfbsrc.c
libgstrfbsrc_la_CFLAGS = $(GST_CFLAGS) -I$(srcdir)/..
-libgstrfbsrc_la_LIBADD = librfb.la
+libgstrfbsrc_la_LIBADD = $(GST_BASE_LIBS) librfb.la
libgstrfbsrc_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+librfb_la_SOURCES = \
+ rfbbuffer.c \
+ rfbdecoder.c \
+ rfbbytestream.c
+librfb_la_CFLAGS = $(GST_CFLAGS) -I$(srcdir)/..
+librfb_la_LIBADD = $(GLIB_LIBS)
noinst_HEADERS = \
rfb.h \
rfbdecoder.h \
rfbbuffer.h \
- rfbbytestream.h
-
-librfb_la_SOURCES = \
- rfb.h \
- rfbdecoder.c \
- rfbdecoder.h \
- rfbbuffer.c \
- rfbbuffer.h \
- rfbbytestream.c \
rfbbytestream.h \
- gstrfbsrc.c
-
-librfb_la_CFLAGS = $(GST_CFLAGS) -I$(srcdir)/..
-librfb_la_LIBADD = $(GLIB_LIBS)
-
+ rfbcontext.h \
+ rfbutil.h \
+ gstrfbsrc.h