summaryrefslogtreecommitdiffstats
path: root/gst/mpeg2sub/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/mpeg2sub/Makefile.am')
-rw-r--r--gst/mpeg2sub/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/gst/mpeg2sub/Makefile.am b/gst/mpeg2sub/Makefile.am
new file mode 100644
index 00000000..d8bfe888
--- /dev/null
+++ b/gst/mpeg2sub/Makefile.am
@@ -0,0 +1,18 @@
+filterdir = $(libdir)/gst
+
+filter_LTLIBRARIES = libgstmpeg2subt.la
+
+libgstmpeg2subt_la_SOURCES = gstmpeg2subt.c
+
+if HAVE_CPU_I386
+ARCHCFLAGS = -m486
+else
+ARCHCFLAGS =
+endif
+
+libgstmpeg2subt_la_CFLAGS = -O3 $(ARCHCFLAGS) -fschedule-insns2 $(FOMIT_FRAME_POINTER) -finline-functions -ffast-math $(GST_CFLAGS)
+
+noinst_HEADERS = gstmpeg2subt.h
+
+EXTRA_DIST = Notes.txt
+