summaryrefslogtreecommitdiffstats
path: root/gst/mpegtsmux/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/mpegtsmux/Makefile.am')
-rw-r--r--gst/mpegtsmux/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/gst/mpegtsmux/Makefile.am b/gst/mpegtsmux/Makefile.am
new file mode 100644
index 00000000..a1d76139
--- /dev/null
+++ b/gst/mpegtsmux/Makefile.am
@@ -0,0 +1,17 @@
+plugin_LTLIBRARIES = libgstmpegtsmux.la
+
+SUBDIRS = tsmux
+
+libgstmpegtsmux_la_SOURCES = \
+ mpegtsmux.c \
+ mpegtsmux_h264.c \
+ mpegtsmux_aac.c
+
+libgstmpegtsmux_la_CFLAGS = $(GST_CFLAGS)
+libgstmpegtsmux_la_LIBADD = $(top_builddir)/gst/mpegtsmux/tsmux/libtsmux.la $(GST_LIBS) $(GST_BASE_LIBS)
+libgstmpegtsmux_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+
+noinst_HEADERS = \
+ mpegtsmux.h \
+ mpegtsmux_h264.h \
+ mpegtsmux_aac.h