summaryrefslogtreecommitdiffstats
path: root/gst/real/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/real/Makefile.am')
-rw-r--r--gst/real/Makefile.am11
1 files changed, 8 insertions, 3 deletions
diff --git a/gst/real/Makefile.am b/gst/real/Makefile.am
index 63696591..d49e3637 100644
--- a/gst/real/Makefile.am
+++ b/gst/real/Makefile.am
@@ -5,10 +5,15 @@ libgstreal_la_SOURCES = \
gstrealaudiodec.c \
gstreal.c
-libgstreal_la_CFLAGS = $(GST_BASE_CFLAGS) $(GST_CFLAGS)
-libgstreal_la_LIBADD = $(GST_BASE_LIBS)
+libgstreal_la_CFLAGS = \
+ $(GST_PLUGINS_BASE_CFLAGS) \
+ $(GST_BASE_CFLAGS) \
+ $(GST_CFLAGS)
+libgstreal_la_LIBADD = \
+ $(GST_PLUGINS_BASE_LIBS) -lgstaudio-@GST_MAJORMINOR@ \
+ $(GST_BASE_LIBS)
libgstreal_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
noinst_HEADERS = \
gstrealvideodec.h \
- gstrealaudiodec.h \ No newline at end of file
+ gstrealaudiodec.h