summaryrefslogtreecommitdiffstats
path: root/gst/xdgmime/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'gst/xdgmime/Makefile.am')
-rw-r--r--gst/xdgmime/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/gst/xdgmime/Makefile.am b/gst/xdgmime/Makefile.am
new file mode 100644
index 00000000..768e3f81
--- /dev/null
+++ b/gst/xdgmime/Makefile.am
@@ -0,0 +1,26 @@
+plugin_LTLIBRARIES = libgstxdgmime.la
+
+libgstxdgmime_la_SOURCES = gstxdgmime.c \
+ xdgmime/xdgmimealias.c \
+ xdgmime/xdgmime.c \
+ xdgmime/xdgmimecache.c \
+ xdgmime/xdgmimeglob.c \
+ xdgmime/xdgmimeicon.c \
+ xdgmime/xdgmimeint.c \
+ xdgmime/xdgmimemagic.c \
+ xdgmime/xdgmimeparent.c
+libgstxdgmime_la_CFLAGS = $(GST_CFLAGS) -DXDG_PREFIX=gst_xdg_mime
+libgstxdgmime_la_LIBADD = $(GST_LIBS)
+libgstxdgmime_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)
+libgstxdgmime_la_LIBTOOLFLAGS = --tag=disable-static
+
+noinst_HEADERS = xdgmime/xdgmimealias.h \
+ xdgmime/xdgmimecache.h \
+ xdgmime/xdgmimeglob.h \
+ xdgmime/xdgmime.h \
+ xdgmime/xdgmimeicon.h \
+ xdgmime/xdgmimeint.h \
+ xdgmime/xdgmimemagic.h \
+ xdgmime/xdgmimeparent.h
+
+EXTRA_DIST =