summaryrefslogtreecommitdiffstats
path: root/sys/directsound/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sys/directsound/Makefile.am')
-rw-r--r--sys/directsound/Makefile.am9
1 files changed, 9 insertions, 0 deletions
diff --git a/sys/directsound/Makefile.am b/sys/directsound/Makefile.am
new file mode 100644
index 00000000..b8b26469
--- /dev/null
+++ b/sys/directsound/Makefile.am
@@ -0,0 +1,9 @@
+plugin_LTLIBRARIES = libgstdirectsoundsink.la
+
+libgstdirectsoundsink_la_SOURCES = gstdirectsoundsink.c gstdirectsoundplugin.c
+libgstdirectsoundsink_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS) \
+ $(GST_PLUGINS_BASE_CFLAGS)
+libgstdirectsoundsink_la_LIBADD = $(DIRECTSOUND_LIBS) \
+ $(GST_BASE_LIBS) $(GST_PLUGINS_BASE_LIBS) \
+ -lgstaudio-$(GST_MAJORMINOR) -lgstinterfaces-$(GST_MAJORMINOR)
+libgstdirectsoundsink_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS)