summaryrefslogtreecommitdiffstats
path: root/sys/qtwrapper/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'sys/qtwrapper/Makefile.am')
-rw-r--r--sys/qtwrapper/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/sys/qtwrapper/Makefile.am b/sys/qtwrapper/Makefile.am
new file mode 100644
index 00000000..db086477
--- /dev/null
+++ b/sys/qtwrapper/Makefile.am
@@ -0,0 +1,24 @@
+plugin_LTLIBRARIES = libgstqtwrapper.la
+
+# sources used to compile this plug-in
+libgstqtwrapper_la_SOURCES = \
+ qtwrapper.c \
+ qtutils.c \
+ codecmapping.c \
+ audiodecoders.c \
+ videodecoders.c \
+ imagedescription.c
+
+# flags used to compile this plugin
+# add other _CFLAGS and _LIBS as needed
+libgstqtwrapper_la_CFLAGS = $(GST_CFLAGS) $(GST_BASE_CFLAGS)
+libgstqtwrapper_la_LIBADD = $(GST_LIBS) $(GST_BASE_LIBS)
+libgstqtwrapper_la_LDFLAGS = $(GST_PLUGIN_LDFLAGS) -Wl,-framework,CoreAudio,-framework,AudioToolbox,-framework,Carbon,-framework,QuickTime,-framework,QuartzCore
+
+
+# headers we need but don't want installed
+noinst_HEADERS = \
+ codecmapping.h \
+ qtwrapper.h \
+ qtutils.h \
+ imagedescription.h