summaryrefslogtreecommitdiffstats
path: root/tests/check/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/check/Makefile.am')
-rw-r--r--tests/check/Makefile.am8
1 files changed, 7 insertions, 1 deletions
diff --git a/tests/check/Makefile.am b/tests/check/Makefile.am
index 3df83e7b..d5d5ac47 100644
--- a/tests/check/Makefile.am
+++ b/tests/check/Makefile.am
@@ -26,10 +26,16 @@ SUPPRESSIONS = $(top_srcdir)/common/gst.supp
clean-local: clean-local-check
+if USE_MPEG2ENC
+check_mpeg2enc = elements/mpeg2enc
+else
+check_mpeg2enc =
+endif
+
check_PROGRAMS = \
elements/gdppay \
elements/gdpdepay \
- elements/mpeg2enc
+ $(check_mpeg2enc)
TESTS = $(check_PROGRAMS)