summaryrefslogtreecommitdiffstats
path: root/tests/check/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/check/Makefile.am')
-rw-r--r--tests/check/Makefile.am10
1 files changed, 9 insertions, 1 deletions
diff --git a/tests/check/Makefile.am b/tests/check/Makefile.am
index 0cc65741..abaf2300 100644
--- a/tests/check/Makefile.am
+++ b/tests/check/Makefile.am
@@ -35,6 +35,12 @@ else
check_mpeg2enc =
endif
+if USE_MPLEX
+check_mplex = elements/mplex
+else
+check_mplex =
+endif
+
if USE_NEON
check_neon = elements/neonhttpsrc
else
@@ -55,7 +61,8 @@ endif
VALGRIND_TO_FIX = \
- elements/mpeg2enc
+ elements/mpeg2enc \
+ elements/mplex
# valgrind testing
VALGRIND_TESTS_DISABLE = \
@@ -64,6 +71,7 @@ VALGRIND_TESTS_DISABLE = \
check_PROGRAMS = \
generic/states \
$(check_mpeg2enc) \
+ $(check_mplex) \
$(check_neon) \
$(check_soup) \
$(check_timidity) \