summaryrefslogtreecommitdiffstats
path: root/tests/examples/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/examples/Makefile.am')
-rw-r--r--tests/examples/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/tests/examples/Makefile.am b/tests/examples/Makefile.am
new file mode 100644
index 00000000..323ced50
--- /dev/null
+++ b/tests/examples/Makefile.am
@@ -0,0 +1,14 @@
+if HAVE_GTK
+GTK_EXAMPLES=scaletempo
+else
+GTK_EXAMPLES=
+endif
+
+if USE_DIRECTFB
+DIRECTFB_DIR=directfb
+else
+DIRECTFB_DIR=
+endif
+
+SUBDIRS= $(DIRECTFB_DIR) $(GTK_EXAMPLES) switch
+DIST_SUBDIRS= directfb switch scaletempo