From 7dc81ddbcce806c74f57890577ee49dc300b8dde Mon Sep 17 00:00:00 2001
From: Benjamin Otte <otte@gnome.org>
Date: Sun, 14 Mar 2004 10:33:44 +0000
Subject: move gstreamer-gconf pkgconfig files to pkgconfig/ dir. Make sure
 they get rebuilt properly

Original commit message from CVS:
* configure.ac:
* gst-libs/gst/gconf/Makefile.am:
* pkgconfig/Makefile.am:
move gstreamer-gconf pkgconfig files to pkgconfig/ dir. Make sure
they get rebuilt properly
* configure.ac:
when checking for vorbis, try pkgconfig first.
* gst/modplug/gstmodplug.cc:
add fixate function
---
 pkgconfig/Makefile.am | 18 ++++++------------
 1 file changed, 6 insertions(+), 12 deletions(-)

(limited to 'pkgconfig/Makefile.am')

diff --git a/pkgconfig/Makefile.am b/pkgconfig/Makefile.am
index 36bca352..cad9e26e 100644
--- a/pkgconfig/Makefile.am
+++ b/pkgconfig/Makefile.am
@@ -8,16 +8,18 @@ endif
 
 ### all of the standard pc files we need to generate
 pcfiles =  \
+	$(GCONF_PC) \
 	gstreamer-libs-@GST_MAJORMINOR@.pc \
 	gstreamer-play-@GST_MAJORMINOR@.pc \
 	gstreamer-interfaces-@GST_MAJORMINOR@.pc
 pcfiles_uninstalled = \
+	$(GCONF_PC_UNINSTALLED) \
 	gstreamer-libs-@GST_MAJORMINOR@-uninstalled.pc \
 	gstreamer-play-@GST_MAJORMINOR@-uninstalled.pc \
 	gstreamer-interfaces-@GST_MAJORMINOR@-uninstalled.pc
 
 pcfiles_gconf = $(GCONF_PC) $(GCONF_PC_UNINSTALLED)
-all-local: $(pcfiles) $(pcfiles_uninstalled) $(pcfiles_gconf)
+all-local: $(pcfiles) $(pcfiles_uninstalled)
 
 ### how to generate pc files from .pc files in this dir
 $(pcfiles): %-@GST_MAJORMINOR@.pc: %.pc
@@ -25,16 +27,6 @@ $(pcfiles): %-@GST_MAJORMINOR@.pc: %.pc
 $(pcfiles_uninstalled): %-@GST_MAJORMINOR@-uninstalled.pc: %-uninstalled.pc
 	cp $< $@
 
-### how to generate gconf dir pc files from their pc.in files
-### somebody smart could figure out how to fold this back into one rule
-$(top_builddir)/gst-libs/gst/gconf/gstreamer-gconf*.pc:
-	cd $(top_builddir)/gst-libs/gst/gconf && make gstreamer-gconf.pc gstreamer-gconf-uninstalled.pc
-
-### how to generate pc files from base .pc file in other dir
-$(pcfiles_gconf): gstreamer-gconf-@GST_MAJORMINOR@%.pc: \
-	$(top_builddir)/gst-libs/gst/gconf/gstreamer-gconf%.pc
-	cp $< $@
-
 pkgconfigdir = $(libdir)/pkgconfig
 pkgconfig_DATA = \
 	$(GCONF_PC) \
@@ -42,7 +34,9 @@ pkgconfig_DATA = \
 	gstreamer-play-@GST_MAJORMINOR@.pc \
 	gstreamer-interfaces-@GST_MAJORMINOR@.pc
 
-CLEANFILES = $(pcfiles) $(pcfiles_uninstalled) $(GCONF_PC) $(GCONF_PC_UNINSTALLED)
+CLEANFILES = $(pcfiles) $(pcfiles_uninstalled)
 EXTRA_DIST= \
+           gstreamer-gconf.pc.in gstreamer-gconf-uninstalled.pc.in \
+           gstreamer-interfaces.pc.in gstreamer-interfaces-uninstalled.pc.in \
            gstreamer-libs.pc.in gstreamer-libs-uninstalled.pc.in \
            gstreamer-play.pc.in gstreamer-play-uninstalled.pc.in
-- 
cgit v1.2.1