#!/usr/bin/make -f

#export DH_VERBOSE=1
export DH_COMPAT=3
export DH_OPTIONS

# GStreamer runtime version required
rtversion=0.4.1

# The plugins are basically the same.
# Link special names to a template file.
# still need "*.files" to be done by hand

PLUGINS=a52dec aa alsa arts artsd audiofile avifile cdparanoia colorspace dv dvd esd festival flac gnomevfs gsm http jack jpeg mad mikmod misc mpeg2dec oss sdl sid vorbis x

setup-links:
	for i in $(PLUGINS); do \
		(cd debian; \
		ln -fs gstreamer-plugin-template.postinst \
			gstreamer-$$i.postinst; \
		ln -fs gstreamer-plugin-template.postrm \
			gstreamer-$$i.postrm; \
		) \
	done

export DEB_HOST_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
export DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)

ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
	confflags += --build $(DEB_HOST_GNU_TYPE)
else
	confflags += --build $(DEB_BUILD_GNU_TYPE) --host $(DEB_HOST_GNU_TYPE)
endif

debian/control: debian/rules debian/control.in debian/build-deps
	debian/mk.control | sed 's/@RTVERSION@/$(rtversion)/g' >debian/control

configure: configure-stamp
configure-stamp:
	dh_testdir

	# make sure we're using a ltmain.sh that can handle relinking
	# in case autogen.sh (and libtoolize) was run
	cp ltmain-fixed.sh ltmain.sh

	# Add here commands to configure the package.
	./configure \
		$(confflags) \
		--prefix=/usr \
		--mandir=\$${prefix}/share/man \
		--infodir=\$${prefix}/share/info \
		--sysconfdir=/etc \
		--disable-tests \
		--disable-examples \
		--disable-docs-build \
		--disable-plugin-docs \
		--enable-DEBUG \
		--enable-debug

	touch configure-stamp

build: configure-stamp build-stamp
build-stamp:
	dh_testdir

	# Add here commands to compile the package.
	$(MAKE)

	touch build-stamp

clean:
	dh_testdir
	dh_testroot
	rm -f build-stamp configure-stamp

	# why does distclean not get the docs? who knows?
	-(cd docs; $(MAKE) clean)
	-$(MAKE) distclean

	dh_clean

	# get rid of the sym links
	for i in $(PLUGINS); do \
		rm -f debian/gstreamer-$$i.postinst; \
		rm -f debian/gstreamer-$$i.postrm; \
	done

install: DH_OPTIONS=
install: build
	dh_testdir
	dh_testroot
	dh_clean -k
	dh_installdirs

	# Add here commands to install the package into debian/gst-plugins.
	GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 \
	DESTDIR=$(CURDIR)/debian/gst-plugins \
	$(MAKE) prefix=$(DESTDIR)/usr install

	dh_movefiles --sourcedir=debian/gst-plugins

# Build architecture-independent files here.
# Pass -i to all debhelper commands in this target to reduce clutter.
binary-indep: DH_OPTIONS=-i
binary-indep: build install
# Need this version of debhelper for DH_OPTIONS to work.
	dh_testdir
	dh_testroot
	dh_installdocs -A debian/README.Debian
	dh_installexamples
	dh_installmenu
	dh_installman
	dh_installchangelogs
	dh_strip
	dh_compress
	dh_fixperms
	dh_installdeb
	dh_gencontrol
	dh_md5sums
	dh_builddeb

# Build architecture-dependent files here.
# Pass -a to all debhelper commands in this target to reduce clutter.
binary-arch: DH_OPTIONS=-a
binary-arch: build install setup-links
# Need this version of debhelper for DH_OPTIONS to work.
	dh_testdir
	dh_testroot
	dh_installdocs -A debian/README.Debian
	dh_installexamples
	dh_installmenu
	dh_installman
	dh_installchangelogs
	dh_strip
	dh_compress
	dh_fixperms
	dh_makeshlibs
	dh_installdeb
	dh_shlibdeps
	dh_gencontrol
	dh_md5sums
	dh_builddeb

#binary: binary-indep binary-arch
binary: binary-arch
.PHONY: build clean binary-indep binary-arch binary install configure