summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac48
1 files changed, 23 insertions, 25 deletions
diff --git a/configure.ac b/configure.ac
index 8ab72ef3..5b01614d 100644
--- a/configure.ac
+++ b/configure.ac
@@ -7,15 +7,15 @@ AC_CONFIG_AUX_DIR([config])
################### SOURCES
# Ingen
+AC_CONFIG_SRCDIR([src/client/OSCController.cpp])
AC_CONFIG_SRCDIR([src/common/interface/EngineInterface.hpp])
AC_CONFIG_SRCDIR([src/common/lv2ext/lv2-miditype.h])
-AC_CONFIG_SRCDIR([src/libs/module/Module.cpp])
-AC_CONFIG_SRCDIR([src/libs/shared/LV2URIMap.cpp])
-AC_CONFIG_SRCDIR([src/libs/engine/JackAudioDriver.cpp])
-AC_CONFIG_SRCDIR([src/libs/serialisation/Loader.cpp])
-AC_CONFIG_SRCDIR([src/libs/client/OSCController.cpp])
-AC_CONFIG_SRCDIR([src/libs/gui/App.cpp])
-AC_CONFIG_SRCDIR([src/progs/ingen/main.cpp])
+AC_CONFIG_SRCDIR([src/engine/JackAudioDriver.cpp])
+AC_CONFIG_SRCDIR([src/gui/App.cpp])
+AC_CONFIG_SRCDIR([src/ingen/main.cpp])
+AC_CONFIG_SRCDIR([src/module/Module.cpp])
+AC_CONFIG_SRCDIR([src/serialisation/Loader.cpp])
+AC_CONFIG_SRCDIR([src/shared/LV2URIMap.cpp])
AC_CONFIG_HEADER([config/config.h])
@@ -313,28 +313,26 @@ AM_CONDITIONAL(BUILD_CLIENT_LIB, [test "$build_ingen_clients" = "yes" -o "$build
# Ingen
AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([doc/Doxyfile])
+AC_CONFIG_FILES([patches/Makefile])
AC_CONFIG_FILES([src/Makefile])
+AC_CONFIG_FILES([src/bindings/Makefile])
+AC_CONFIG_FILES([src/client/Makefile])
AC_CONFIG_FILES([src/common/Makefile])
AC_CONFIG_FILES([src/common/interface/Makefile])
AC_CONFIG_FILES([src/common/lv2ext/Makefile])
-AC_CONFIG_FILES([src/libs/Makefile])
-AC_CONFIG_FILES([src/libs/module/Makefile])
-AC_CONFIG_FILES([src/libs/shared/Makefile])
-AC_CONFIG_FILES([src/libs/engine/Makefile])
-AC_CONFIG_FILES([src/libs/engine/events/Makefile])
-AC_CONFIG_FILES([src/libs/serialisation/Makefile])
-AC_CONFIG_FILES([src/libs/client/Makefile])
-AC_CONFIG_FILES([src/libs/gui/Makefile])
-AC_CONFIG_FILES([src/bindings/Makefile])
-AC_CONFIG_FILES([src/progs/Makefile])
-AC_CONFIG_FILES([src/progs/ingen/Makefile])
-AC_CONFIG_FILES([src/progs/supercollider/Makefile])
-AC_CONFIG_FILES([src/progs/python/Makefile])
-AC_CONFIG_FILES([src/progs/python/scripts/Makefile])
-AC_CONFIG_FILES([src/progs/ingen/ingen.desktop])
-AC_CONFIG_FILES([patches/Makefile])
-AC_CONFIG_FILES([doc/Doxyfile])
-
+AC_CONFIG_FILES([src/engine/Makefile])
+AC_CONFIG_FILES([src/engine/events/Makefile])
+AC_CONFIG_FILES([src/gui/Makefile])
+AC_CONFIG_FILES([src/ingen/Makefile])
+AC_CONFIG_FILES([src/ingen/ingen.desktop])
+AC_CONFIG_FILES([src/module/Makefile])
+AC_CONFIG_FILES([src/scripts/Makefile])
+AC_CONFIG_FILES([src/scripts/python/Makefile])
+AC_CONFIG_FILES([src/scripts/python/scripts/Makefile])
+AC_CONFIG_FILES([src/scripts/supercollider/Makefile])
+AC_CONFIG_FILES([src/serialisation/Makefile])
+AC_CONFIG_FILES([src/shared/Makefile])
AC_OUTPUT