summaryrefslogtreecommitdiffstats
path: root/src/serialisation/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/serialisation/Makefile.am')
-rw-r--r--src/serialisation/Makefile.am24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/serialisation/Makefile.am b/src/serialisation/Makefile.am
new file mode 100644
index 00000000..57e99055
--- /dev/null
+++ b/src/serialisation/Makefile.am
@@ -0,0 +1,24 @@
+MAINTAINERCLEANFILES = Makefile.in
+
+moduledir = $(libdir)/ingen
+
+module_LTLIBRARIES = libingen_serialisation.la
+
+libingen_serialisation_la_CXXFLAGS = \
+ @INGEN_CFLAGS@ \
+ @REDLANDMM_CFLAGS@ \
+ @RAUL_CFLAGS@ \
+ @GLIBMM_CFLAGS@ \
+ @SLV2_CFLAGS@
+
+libingen_serialisation_la_LDFLAGS = -no-undefined -module -avoid-version
+libingen_serialisation_la_LIBADD = @RAUL_LIBS@ @REDLANDMM_LIBS@ @GLIBMM_LIBS@ @SLV2_LIBS@
+
+libingen_serialisation_la_SOURCES = \
+ Parser.cpp \
+ Parser.hpp \
+ Serialiser.cpp \
+ Serialiser.hpp \
+ serialisation.cpp \
+ serialisation.hpp
+