summaryrefslogtreecommitdiffstats
path: root/src/shared/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/shared/Makefile.am')
-rw-r--r--src/shared/Makefile.am22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/shared/Makefile.am b/src/shared/Makefile.am
new file mode 100644
index 00000000..c26c98a2
--- /dev/null
+++ b/src/shared/Makefile.am
@@ -0,0 +1,22 @@
+noinst_LTLIBRARIES = libingen_shared.la
+
+libingen_shared_la_CXXFLAGS = \
+ @GLIBMM_CFLAGS@ \
+ @INGEN_CFLAGS@ \
+ @RAUL_CFLAGS@ \
+ @REDLANDMM_CFLAGS@ \
+ @SLV2_CFLAGS@
+
+libingen_shared_la_SOURCES = \
+ Builder.cpp \
+ Builder.hpp \
+ ClashAvoider.cpp \
+ ClashAvoider.hpp \
+ LV2Features.cpp \
+ LV2Features.hpp \
+ LV2URIMap.cpp \
+ LV2URIMap.hpp \
+ OSCSender.cpp \
+ OSCSender.hpp \
+ Store.cpp \
+ Store.hpp