summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2007-05-09 01:34:35 +0000
committerDavid Robillard <d@drobilla.net>2007-05-09 01:34:35 +0000
commit3433ad241b069037d780c528ff462b3ce7c2c3be (patch)
treecb7caceaf721cbc7d658a814838dcd924356fb02 /Makefile.am
parent9b0b42f31a6e03a5caed14cd73802729c31b6b6e (diff)
downloadlilv-3433ad241b069037d780c528ff462b3ce7c2c3be.tar.gz
lilv-3433ad241b069037d780c528ff462b3ce7c2c3be.tar.bz2
lilv-3433ad241b069037d780c528ff462b3ce7c2c3be.zip
Ontology install path fixes.
0.0.1 versioning stuff. Removed GNU 'standard' files I don't maintain anyway and make automake shutup about it. git-svn-id: http://svn.drobilla.net/lad/slv2@521 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 66af074..8497095 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,21 @@
-SUBDIRS = src slv2 utils hosts data doc
+AUTOMAKE_OPTIONS = foreign
+
+if HAVE_DOXYGEN
+DOC_DIR = doc
+dist-check-doxygen:
+else
+DOC_DIR =
+dist-check-doxygen:
+ @echo
+ @echo ' ******' You need doxygen installed to make dist.' ******'
+ @echo
+ @false
+endif
+
+SUBDIRS = src slv2 utils hosts data $(DOC_DIR)
+DIST_SUBDIRS = src slv2 utils hosts data doc
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libslv2.pc
+dist-hook: dist-check-doxygen