summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2007-02-07 01:45:53 +0000
committerDavid Robillard <d@drobilla.net>2007-02-07 01:45:53 +0000
commit17ec1c5594772a89a5284449754b56ccb705ebe4 (patch)
treed3ee843acc698345b3760818b1a09f55a18517bb /configure.ac
parent87e016baff11bd74d905b68e48577461b36b992c (diff)
downloadlilv-17ec1c5594772a89a5284449754b56ccb705ebe4.tar.gz
lilv-17ec1c5594772a89a5284449754b56ccb705ebe4.tar.bz2
lilv-17ec1c5594772a89a5284449754b56ccb705ebe4.zip
Added lv2.ttl installation, lv2.ttl added as source by default to queries.
Changed port API to work by referring to either index or symbol. Plugged some leaks. Added access to plugin/port hints/properties. Updated lv2.ttl. git-svn-id: http://svn.drobilla.net/lad/slv2@285 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac14
1 files changed, 13 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 2485744..bbc7590 100644
--- a/configure.ac
+++ b/configure.ac
@@ -81,6 +81,17 @@ if test "$build_ladspa2lv2" = "yes"; then
fi
AM_CONDITIONAL(BUILD_LADSPA2SLV2, [test "$build_ladspa2lv2" = "yes"])
+
+# Check ontology install directory
+AC_MSG_CHECKING([where to install lv2.ttl])
+AC_ARG_WITH(lv2-ttl-dir,
+ AS_HELP_STRING([--with-lv2-ttl-dir=DIR],
+ [directory where lv2.ttl should be installed ($datadir/lv2)]),
+ [lv2ttldir=$withval], [lv2ttldir=$datadir/lv2])
+AC_MSG_RESULT($lv2ttldir)
+lv2ttlpath="$lv2ttldir/lv2.ttl"
+AC_SUBST(lv2ttlpath)
+
# Write output files
AC_CONFIG_FILES([Makefile])
AC_CONFIG_FILES([src/Makefile])
@@ -98,7 +109,8 @@ AC_MSG_RESULT([])
AC_MSG_RESULT([**********************************************************************])
AC_MSG_RESULT([SLV2 build configuration:])
AC_MSG_RESULT([])
-AC_MSG_RESULT([Building JACK clients: $build_jack])
+AC_MSG_RESULT([Building JACK clients: $build_jack])
+AC_MSG_RESULT([Ontology install location: $lv2ttlpath])
AC_MSG_RESULT([**********************************************************************])
AC_MSG_RESULT([])