summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2007-07-29 17:20:23 +0000
committerDavid Robillard <d@drobilla.net>2007-07-29 17:20:23 +0000
commitadd7dd9f6b1bc17519d7c64282a7f2295735951c (patch)
tree8d11bb0aa787fa563ca18471c795ca90d8429a1d /configure.ac
parentbd6f6beb3137bb637aced8b68873513b4c7dc769 (diff)
downloadlilv-add7dd9f6b1bc17519d7c64282a7f2295735951c.tar.gz
lilv-add7dd9f6b1bc17519d7c64282a7f2295735951c.tar.bz2
lilv-add7dd9f6b1bc17519d7c64282a7f2295735951c.zip
Build system fixes, building from top level doesn't recursively configure slv2, but slv2 is still independently packageable/buildable.
Think I've finally figured out how to do recursive autohell without resorting to suicide... git-svn-id: http://svn.drobilla.net/lad/slv2@650 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac22
1 files changed, 15 insertions, 7 deletions
diff --git a/configure.ac b/configure.ac
index 91117ee..56700e1 100644
--- a/configure.ac
+++ b/configure.ac
@@ -29,15 +29,23 @@ AM_INIT_AUTOMAKE
SLV2_SO_VERSION=${SLV2_API_CURRENT}:${SLV2_API_REVISION}:${SLV2_API_AGE}
AC_SUBST(SLV2_SO_VERSION)
+# This is cute... autohell FTW
+builddir=`pwd`
+cd $srcdir
+abs_srcdir=`pwd`
+cd $builddir
+
+SLV2_CFLAGS="-I$abs_srcdir"
+SLV2_LIBS="$abs_srcdir/src/.libs/libslv2.la"
+AC_SUBST(SLV2_CFLAGS)
+AC_SUBST(SLV2_LIBS)
+
+CONFIG_H_PATH="$builddir/config/config.h"
+AC_SUBST(CONFIG_H_PATH)
+AC_DEFINE(CONFIG_H_PATH, ["$CONFIG_H_PATH"], [Absolute location of config.h for this build])
+
# Checks for compiler
AC_PROG_CC
-AM_PROG_CC_C_O
-
-# Check pedantic other stuff autoscan says we should :)
-AC_C_CONST
-AC_C_INLINE
-AC_HEADER_STDBOOL
-AC_TYPE_SIZE_T
# Library building stuff
AC_PROG_LIBTOOL