summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2008-02-17 03:44:47 +0000
committerDavid Robillard <d@drobilla.net>2008-02-17 03:44:47 +0000
commitaf851c8032f8dd4e65edf9664700c2c8b35906a3 (patch)
treef30f33b8c76315f70cd73c8d8a6e2fee6609d094 /configure.ac
parent8528011e19f061258f1723645d7202305b529f0e (diff)
downloadlilv-af851c8032f8dd4e65edf9664700c2c8b35906a3.tar.gz
lilv-af851c8032f8dd4e65edf9664700c2c8b35906a3.tar.bz2
lilv-af851c8032f8dd4e65edf9664700c2c8b35906a3.zip
Check for Python properly before attempting to build bindings.
Preliminary scheme (chicken/mzscheme) bindings (not working). git-svn-id: http://svn.drobilla.net/lad/slv2@1146 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac12
1 files changed, 9 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 79ac998..05a425a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -96,9 +96,9 @@ if test "$strict" = "yes"; then
fi
# SWIG bindings
-bindings="yes"
+bindings="no"
AC_ARG_ENABLE(bindings,
- [AS_HELP_STRING(--enable-bindings, [Build language bindings via SWIG (true if available)])],
+ [AS_HELP_STRING(--enable-bindings, [Build language bindings via SWIG (false)])],
[bindings="$enableval"])
if test "$bindings" = "yes"; then
AC_CHECK_PROGS(SWIG, "swig swig-1.3")
@@ -108,11 +108,17 @@ if test "$bindings" = "yes"; then
fi
AM_CONDITIONAL(WITH_SWIG, [test "$bindings" = "yes"])
-python="no"
+# Check for binding languages
+mzscheme="no"
+chicken="no"
if test "$bindings" = "yes"; then
AC_PYTHON_DEVEL([>= '2.3.0'])
+ AC_CHECK_HEADER([plt/escheme.h], [mzscheme="yes"], [mzscheme="no"])
+ AC_CHECK_HEADER([chicken.h], [chicken="yes"], [chicken="no"])
fi
AM_CONDITIONAL(WITH_PYTHON, [test ! "$PYTHON_VERSION" = "yes"])
+AM_CONDITIONAL(WITH_MZSCHEME, [test "$mzscheme" = "yes"])
+AM_CONDITIONAL(WITH_CHICKEN, [test "$chicken" = "yes"])
# Check for Redland
build_redland="no"