summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2008-02-02 23:49:03 +0000
committerDavid Robillard <d@drobilla.net>2008-02-02 23:49:03 +0000
commitb23235402b2e0770b6599a413ba364337755e704 (patch)
tree6f4b7178a7146298114c7be0878f5aebc0708676 /configure.ac
parent09a9c69a384fb01515bd55496649ca0b887ab07f (diff)
downloadlilv-b23235402b2e0770b6599a413ba364337755e704.tar.gz
lilv-b23235402b2e0770b6599a413ba364337755e704.tar.bz2
lilv-b23235402b2e0770b6599a413ba364337755e704.zip
Revert to stupid pre-pkg-config idiotic bullshit.
git-svn-id: http://svn.drobilla.net/lad/slv2@1129 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac34
1 files changed, 29 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index d136dc8..dced69b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -109,12 +109,36 @@ AM_CONDITIONAL(WITH_SWIG, [test "$bindings" = "yes"])
build_redland="no"
AC_CHECK_PROG(REDLAND_CONFIG, redland-config, redland-config)
if test "X$REDLAND_CONFIG" = X; then
- AC_MSG_ERROR([REDLANDMM requires Redland (librdf), but redland-config not found.])
+ AC_MSG_ERROR([REDLANDMM requires Redland (librdf), but redland-config not found.])
else
- build_redland="yes"
- PKG_CHECK_MODULES(RAPTOR, raptor)
- PKG_CHECK_MODULES(RASQAL, rasqal >= 0.9.14)
- PKG_CHECK_MODULES(REDLAND, redland >= 1.0.6)
+ build_redland="yes"
+ PKG_CHECK_MODULES(RAPTOR, raptor)
+ PKG_CHECK_MODULES(RASQAL, rasqal >= 0.9.14)
+ redland_major_version=`$REDLAND_CONFIG --version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
+ redland_minor_version=`$REDLAND_CONFIG --version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
+ redland_micro_version=`$REDLAND_CONFIG --version | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
+ AC_MSG_CHECKING([for REDLAND version >= 1.0.6])
+ version_ok="no"
+ if test 1 -le $redland_major_version; then
+ if test 0 -le $redland_minor_version; then
+ if test 6 -le $redland_micro_version; then
+ version_ok="yes"
+ fi
+ fi
+ fi
+ if test $version_ok = "no"; then
+ act=`$REDLAND_CONFIG --version`
+ AC_MSG_ERROR([REDLAND version >= 1.0.6 required; $act found])
+ else
+ AC_MSG_RESULT([yes])
+ fi
+ REDLAND_CFLAGS=`$REDLAND_CONFIG --cflags`
+ REDLAND_LIBS=`$REDLAND_CONFIG --libs`
+ AC_SUBST(REDLAND_CFLAGS)
+ AC_SUBST(REDLAND_LIBS)
fi
AM_CONDITIONAL(WITH_REDLAND, [test "$build_redland" = "yes"])