summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2006-07-18 00:26:53 +0000
committerDavid Robillard <d@drobilla.net>2006-07-18 00:26:53 +0000
commitc7153b1a3d607108bab6cd8d6719977ffb213092 (patch)
tree055842a6aba4ae37cfe3ad0c01cbb127e28a3263 /configure.ac
parent0e186578b14980d79a4f4df512ec90acc1f15f65 (diff)
downloadlilv-c7153b1a3d607108bab6cd8d6719977ffb213092.tar.gz
lilv-c7153b1a3d607108bab6cd8d6719977ffb213092.tar.bz2
lilv-c7153b1a3d607108bab6cd8d6719977ffb213092.zip
Stricter warning cleanliness
git-svn-id: http://svn.drobilla.net/lad/libslv2@91 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 1 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index fb3ba51..882af74 100644
--- a/configure.ac
+++ b/configure.ac
@@ -27,10 +27,8 @@ AC_ARG_ENABLE(debug,
[debug="$enableval"])
if test "$debug" = "yes"; then
CFLAGS="-O0 -g -DDEBUG"
- CXXFLAGS="$CFLAGS"
else
CFLAGS="$CFLAGS -DNDEBUG"
- CXXFLAGS="$CXXFLAGS -DNDEBUG"
fi
# Check for strict flag
@@ -39,12 +37,10 @@ AC_ARG_ENABLE(strict,
[AS_HELP_STRING(--enable-strict, [Enable strict compiler warnings and errors (false)])],
[strict="$enableval"])
if test "$strict" = "yes"; then
- CFLAGS="$CFLAGS -std=c99 -pedantic -Wall -Wconversion -Winit-self"
- CXXFLAGS="$CXXFLAGS -ansi -pedantic -Wall -Wconversion -Winit-self -Woverloaded-virtual -Wsign-promo"
+ CFLAGS="$CFLAGS -std=c99 -pedantic -Wall -Wextra -Wconversion -Winit-self"
fi
# Bolt on a few specific flags to CXXFLAGS that should always be used
-#CXXFLAGS="$CXXFLAGS -pipe -Wall -fmessage-length=139 -fdiagnostics-show-location=every-line"
#CFLAGS="$CFLAGS -pipe -Wall -fmessage-length=139 -fdiagnostics-show-location=every-line"
# Check plugin install directory