summaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2007-11-15 04:10:33 +0000
committerDavid Robillard <d@drobilla.net>2007-11-15 04:10:33 +0000
commitf509434f4d87337243865d928e4fb2c6124c9cd3 (patch)
treebd06e3b71672279ed67a6302ed4e8f6869c1fe88 /debian
parent85bb5ef9bf1a44fa58f64e16e955d980a64799f6 (diff)
downloadlilv-f509434f4d87337243865d928e4fb2c6124c9cd3.tar.gz
lilv-f509434f4d87337243865d928e4fb2c6124c9cd3.tar.bz2
lilv-f509434f4d87337243865d928e4fb2c6124c9cd3.zip
Add Debian packaging stuff.
Rename pkg-config file libslv2 -> slv2 (conventional). git-svn-id: http://svn.drobilla.net/lad/slv2@916 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'debian')
l---------debian/README1
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control21
-rw-r--r--debian/copyright34
-rw-r--r--debian/dirs2
-rw-r--r--debian/docs1
-rwxr-xr-xdebian/rules106
-rw-r--r--debian/shlibs.local1
-rw-r--r--debian/slv2-dev.dirs2
-rw-r--r--debian/slv2-dev.install6
-rw-r--r--debian/slv21.dirs1
-rw-r--r--debian/slv21.install1
13 files changed, 182 insertions, 0 deletions
diff --git a/debian/README b/debian/README
new file mode 120000
index 0000000..59a23c4
--- /dev/null
+++ b/debian/README
@@ -0,0 +1 @@
+../README \ No newline at end of file
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 0000000..1686531
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+slv2 (0.3.0) unstable; urgency=low
+
+ * Initial Debian Release.
+
+ -- Dave Robillard <dave@drobilla.net> Wed, 14 Nov 2007 22:29:49 -0500
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 0000000..7ed6ff8
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+5
diff --git a/debian/control b/debian/control
new file mode 100644
index 0000000..bcdec15
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,21 @@
+Source: slv2
+Priority: extra
+Maintainer: Dave Robillard <dave@drobilla.net>
+Build-Depends: debhelper (>= 5), autotools-dev
+Standards-Version: 3.7.2
+Section: libs
+
+Package: slv2-dev
+Section: libdevel
+Architecture: any
+Depends: slv2 (= ${binary:Version})
+Description: Development files (headers) for SLV2
+ Files required for compiling programs which use SLV2.
+
+Package: slv2
+Section: libs
+Architecture: any
+Depends: ${shlibs:Depends}, ${misc:Depends}
+Description: A library for simple use of LV2 plugins
+ SLV2 is a library geared towards music and audio applications which makes
+ the use of LV2 plugins <http://lv2plug.in> as simple as possible.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 0000000..97ef279
--- /dev/null
+++ b/debian/copyright
@@ -0,0 +1,34 @@
+This package was debianized by Dave Robillard <dave@drobilla.net> on
+Wed, 14 Nov 2007 22:29:49 -0500.
+
+It was downloaded from <http://drobilla.net/software/slv2>
+
+Upstream Author:
+
+ Dave Robillard <dave@drobilla.net>
+
+Copyright:
+
+ Copyright (C) 2007 Dave Robillard
+
+License:
+
+ This package is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+
+ This package is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+
+ You should have received a copy of the GNU General Public License
+ along with this package; if not, write to the Free Software
+ Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
+
+On Debian systems, the complete text of the GNU General
+Public License can be found in `/usr/share/common-licenses/GPL'.
+
+The Debian packaging is (C) 2007, Dave Robillard <dave@drobilla.net> and
+is licensed under the GPL, see above.
diff --git a/debian/dirs b/debian/dirs
new file mode 100644
index 0000000..ca882bb
--- /dev/null
+++ b/debian/dirs
@@ -0,0 +1,2 @@
+usr/bin
+usr/sbin
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 0000000..e845566
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1 @@
+README
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 0000000..f491e73
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,106 @@
+#!/usr/bin/make -f
+# -*- makefile -*-
+# Sample debian/rules that uses debhelper.
+# This file was originally written by Joey Hess and Craig Small.
+# As a special exception, when this file is copied by dh-make into a
+# dh-make output file, you may use that output file without restriction.
+# This special exception was added by Craig Small in version 0.37 of dh-make.
+
+# Uncomment this to turn on verbose mode.
+#export DH_VERBOSE=1
+
+
+# These are used for cross-compiling and for saving the configure script
+# from having to guess our platform (since we know it already)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+
+
+# shared library versions, option 1
+version=2.0.5
+major=2
+# option 2, assuming the library is created as src/.libs/libfoo.so.2.0.5 or so
+#version=`ls src/.libs/lib*.so.* | \
+# awk '{if (match($$0,/[0-9]+\.[0-9]+\.[0-9]+$$/)) print substr($$0,RSTART)}'`
+#major=`ls src/.libs/lib*.so.* | \
+# awk '{if (match($$0,/\.so\.[0-9]+$$/)) print substr($$0,RSTART+4)}'`
+
+config.status: configure
+ dh_testdir
+ # Add here commands to configure the package.
+ifneq "$(wildcard /usr/share/misc/config.sub)" ""
+ cp -f /usr/share/misc/config.sub config.sub
+endif
+ifneq "$(wildcard /usr/share/misc/config.guess)" ""
+ cp -f /usr/share/misc/config.guess config.guess
+endif
+ ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info CFLAGS="$(CFLAGS)" LDFLAGS="-Wl,-z,defs"
+
+
+build: build-stamp
+build-stamp: config.status
+ dh_testdir
+
+ # Add here commands to compile the package.
+ $(MAKE)
+
+ touch $@
+
+clean:
+ dh_testdir
+ dh_testroot
+ rm -f build-stamp
+
+ # Add here commands to clean up after the build process.
+ $(MAKE) distclean
+ rm -f config.sub config.guess
+
+ dh_clean
+
+install: build
+ dh_testdir
+ dh_testroot
+ dh_clean -k
+ dh_installdirs
+
+ # Add here commands to install the package into debian/tmp
+ $(MAKE) DESTDIR=$(CURDIR)/debian/tmp install
+
+
+# Build architecture-independent files here.
+binary-indep: build install
+# We have nothing to do by default.
+
+# Build architecture-dependent files here.
+binary-arch: build install
+ dh_testdir
+ dh_testroot
+ dh_installchangelogs
+ dh_installdocs
+ dh_installexamples
+# dh_install
+# dh_installmenu
+# dh_installdebconf
+# dh_installlogrotate
+# dh_installemacsen
+# dh_installpam
+# dh_installmime
+# dh_installinit
+# dh_installcron
+# dh_installinfo
+ dh_installman
+ dh_link
+ dh_strip
+ dh_compress
+ dh_fixperms
+# dh_perl
+# dh_python
+# dh_makeshlibs
+ dh_installdeb
+ dh_shlibdeps
+ dh_gencontrol
+ dh_md5sums
+ dh_builddeb
+
+binary: binary-indep binary-arch
+.PHONY: build clean binary-indep binary-arch binary install
diff --git a/debian/shlibs.local b/debian/shlibs.local
new file mode 100644
index 0000000..900307e
--- /dev/null
+++ b/debian/shlibs.local
@@ -0,0 +1 @@
+libslv2 0.3.0 slv2 (>> 0.3.0-0), slv2 (<< 0.3.0-99)
diff --git a/debian/slv2-dev.dirs b/debian/slv2-dev.dirs
new file mode 100644
index 0000000..4418816
--- /dev/null
+++ b/debian/slv2-dev.dirs
@@ -0,0 +1,2 @@
+usr/lib
+usr/include
diff --git a/debian/slv2-dev.install b/debian/slv2-dev.install
new file mode 100644
index 0000000..3c996c8
--- /dev/null
+++ b/debian/slv2-dev.install
@@ -0,0 +1,6 @@
+usr/include/*
+usr/lib/lib*.a
+usr/lib/lib*.so
+usr/lib/pkgconfig/*
+usr/lib/*.la
+usr/share/pkgconfig/*
diff --git a/debian/slv21.dirs b/debian/slv21.dirs
new file mode 100644
index 0000000..6845771
--- /dev/null
+++ b/debian/slv21.dirs
@@ -0,0 +1 @@
+usr/lib
diff --git a/debian/slv21.install b/debian/slv21.install
new file mode 100644
index 0000000..d0dbfd1
--- /dev/null
+++ b/debian/slv21.install
@@ -0,0 +1 @@
+usr/lib/lib*.so.*