summaryrefslogtreecommitdiffstats
path: root/hosts/Makefile.am
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2007-02-05 22:34:56 +0000
committerDavid Robillard <d@drobilla.net>2007-02-05 22:34:56 +0000
commit1988a63b41a0e81f348d5df3394d41d3248d442b (patch)
tree2ec6758a2554f6456ae0f377cc47b4f1260a8b2d /hosts/Makefile.am
parent1f0922ab4982da825ddfbb792ec9f871b2b88804 (diff)
downloadlilv-1988a63b41a0e81f348d5df3394d41d3248d442b.tar.gz
lilv-1988a63b41a0e81f348d5df3394d41d3248d442b.tar.bz2
lilv-1988a63b41a0e81f348d5df3394d41d3248d442b.zip
Reorganized tree in preparation for beta release.
Split simple (example) jack host and more useful one (with midi). Working Jack/LV2 midi in lv2_jack_host. Added lv2_list. git-svn-id: http://svn.drobilla.net/lad/slv2@279 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'hosts/Makefile.am')
-rw-r--r--hosts/Makefile.am18
1 files changed, 18 insertions, 0 deletions
diff --git a/hosts/Makefile.am b/hosts/Makefile.am
new file mode 100644
index 0000000..aa794c5
--- /dev/null
+++ b/hosts/Makefile.am
@@ -0,0 +1,18 @@
+AM_CFLAGS = -std=c99 -I$(top_srcdir) @RASQAL_CFLAGS@
+
+if WITH_JACK
+
+bin_PROGRAMS = lv2_jack_host lv2_simple_jack_host
+
+lv2_jack_host_CFLAGS = @JACK_CFLAGS@ $(AM_CFLAGS)
+
+lv2_jack_host_DEPENDENCIES = ../src/libslv2.la
+lv2_jack_host_LDADD = ../src/libslv2.la @JACK_LIBS@ @RASQAL_LIBS@
+
+lv2_simple_jack_host_LDADD = ../src/libslv2.la @JACK_LIBS@ @RASQAL_LIBS@
+
+lv2_jack_host_SOURCES = \
+ lv2_jack_host.c
+
+endif
+