summaryrefslogtreecommitdiffstats
path: root/swig/Makefile.am
diff options
context:
space:
mode:
authorDavid Robillard <d@drobilla.net>2007-07-31 05:43:43 +0000
committerDavid Robillard <d@drobilla.net>2007-07-31 05:43:43 +0000
commit985fa3a938241a763794c2d445fc5ab26efd6686 (patch)
tree23464dc61484fe0e97b272948c44f593657407a1 /swig/Makefile.am
parentb94d8b912020447ce12c34fe13cbc823557c1703 (diff)
downloadlilv-985fa3a938241a763794c2d445fc5ab26efd6686.tar.gz
lilv-985fa3a938241a763794c2d445fc5ab26efd6686.tar.bz2
lilv-985fa3a938241a763794c2d445fc5ab26efd6686.zip
Added experimental Python bindings via swig.
Fixed building from slv2 directory. git-svn-id: http://svn.drobilla.net/lad/slv2@660 a436a847-0d15-0410-975c-d299462d15a1
Diffstat (limited to 'swig/Makefile.am')
-rw-r--r--swig/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/swig/Makefile.am b/swig/Makefile.am
new file mode 100644
index 0000000..6c12b26
--- /dev/null
+++ b/swig/Makefile.am
@@ -0,0 +1,12 @@
+EXTRA_DIST = slv2.i lv2_list.py
+
+if WITH_SWIG
+all:
+ swig -Wall -python slv2.i
+ gcc -fPIC -shared -I/usr/include/python2.4 slv2_wrap.c ../src/.libs/libslv2.so -o _slv2.so
+endif
+
+clean:
+ rm *.c
+ rm *.so
+ rm *.o