summaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am18
1 files changed, 17 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 66af074..8497095 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1,5 +1,21 @@
-SUBDIRS = src slv2 utils hosts data doc
+AUTOMAKE_OPTIONS = foreign
+
+if HAVE_DOXYGEN
+DOC_DIR = doc
+dist-check-doxygen:
+else
+DOC_DIR =
+dist-check-doxygen:
+ @echo
+ @echo ' ******' You need doxygen installed to make dist.' ******'
+ @echo
+ @false
+endif
+
+SUBDIRS = src slv2 utils hosts data $(DOC_DIR)
+DIST_SUBDIRS = src slv2 utils hosts data doc
pkgconfigdir = $(libdir)/pkgconfig
pkgconfig_DATA = libslv2.pc
+dist-hook: dist-check-doxygen